Jump to content
scissors

AYUDA PARA NO CONTAR CELDAS EN BLANCO O "0"

Recommended Posts

hola amigos del foro,

quisiera pedirles vuestra ayuda !! necesito dejar una celda fuera de formula que promedia los ultimos 7 dias a contar del dia actual(HOY()), si se fijan en archivo adjunto al ingresar en un dia ceros, ya que no hubo resultados, en cuadro % me muestra el 0% resultado del si.error, el problema que el resultado que esta al costado derecho "Average latest 7 days", el cual me promedia los ultimos 7 dias a contar del dia HOY(), se altera y me muestra un dato que no corresponde, al supr manual el dato %, recien ahi me muestra correcto el promedio de los ultimos 7 dias, es un detalle que para muchos datos se verá marcado, MUCHAS GRACIAS !!! 

 

Daily_Check_Up.xlsx

Share this post


Link to post
Share on other sites

en la formula =SI(N3='Daily check up summary'!$C$2;PROMEDIO((DESREF(G4;CONTAR(G4:G507)-8;0;7;1)));0) que esta en celda "Average latest 7 days" en esa formula necesito que solo tome las celdas con datos para contar, que excluya los ceros(<>0) y celdas vacias(""), por ahora lo tengo solo con un contar, y para que me funcione debo suprimir manual las celdas que no tienen valor... espero me entiendan, gracias !!!!

Share this post


Link to post
Share on other sites

¡Hola, @scissors!

¡No es necesario que dupliques los temas!

Puedes usar esta fórmula:

=PROMEDIO.SI(INDICE(G4:G377;AGREGAR(14;6;FILA(G4:G377)-FILA(G3)/(G4:G377>0);7)):INDICE(G4:G377;COINCIDIR(9E+307;G4:G377));"<>0")

¡Bendiciones!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png