Jump to content
  • Debido a la crisis sanitaria, hasta el día 31 de marzo, el registro al foro de Ayuda Excel será totalmente gratuito para facilitar el teletrabajo. Todos los registros que se produzcan entre estas fechas tendrán acceso gratuito ilimitado a la comunidad hasta el 30 de abril.

    Regístrate

    Si te surge alguna duda mientras estás trabajando en casa con Excel, ya tienes a quien preguntar.

    Espero que esta medida te sirva de ayuda. Frenar la expansión del coronavirus depende de todos. Sé responsable.

Sign in to follow this  
CarlosKurt

Buscar datos según el nombre

Recommended Posts

Hola a tod@s.

Antes agradecer por su tiempo en ese nuevo tema que estoy publicando.

En una matriz se necesita buscar las cantidades que se ha comprado un determinado cliente, previa digitación del nombre del cliente.

Lo resolví con las formulas de BUSCARV + COINCIDIR. Sin embargo la planilla original contiene 1000 clientes (columnas) y 15000 productos (filas). Habra formula que pueda reducir el tiempo de cargar los resultados.

Saludos

 

PRUEBA.xlsx

Share this post


Link to post
Share on other sites

con macros reduce el tiempo, tu formula en macros

With Range("I11:I" & Range("H65536").End(xlUp).Row)
    .FormulaR1C1 = "=VLOOKUP(RC[-1],R3C1:R7C4,MATCH(R9C9,R2C1:R2C4,0),0)"
    .Value = .Value
    End With

esto es lo que me enseñaron aquí en este foro pero silvia es experta en formulas

Share this post


Link to post
Share on other sites
Hace 4 horas, Silvia dijo:

hola CarlosKurt

Tengo entendido que Indice con Coincidir es mas económico.. 


=INDICE($B$3:$D$7,COINCIDIR(H11,$A$3:$A$7,),COINCIDIR($I$9,$B$2:$D$2,))

Revisa el adjunto

saludos,

Silvia

 

 

PRUEBA sq.xlsx

Muchas gracias @Silvia y @isidrod

Sus métodos me han servido de mucho.

Doy por terminado el tema.

Saludos.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png