Jump to content
Argantonio

Tablas Anidadas imperfectas :(

Recommended Posts

Buenas. Me ha costado trabajo, pero al final conseguí crear mi primera tabla anidada. Sin embargo queda un detalle importante. 

En E3 hay tres tipos de respuesta: A, B, C. Sólo la respuesta B da opción a los desplegables de F3 y G3.

¿Cómo se consigue que F3 y G3 se queden en blanco si E3 tiene como respuesta A o C?

 

Algo paralelo a esto ocurre luego con la relación entre F3 y G3. 

Al elegir B1 en el desplegable F3, G3 debería aparecer en blanco hasta elegir la respuesta de esta tabla.

 

Bonus track:

¿Qué fórmula (y dónde) haría que se rellenaran A3 y B3 automáticamente al rellenar C3?

A3: Número de llamada: 1, 2, 3, 4... en el momento de rellenar C3.

B3: Fecha y hora en el momento de rellenar C3.

 

GRACIAS :)

 

 

vdd.7z

Share this post


Link to post
Share on other sites

 

Maravilloso, funciona perfectamente, @bigpetroman. Aún no he tenido tiempo de ver en qué fallaba (yo).

Quedan un par de asuntos con los que estoy naufragando, y los creía bien fáciles.

a) A3 me debería dar una numeración automática al rellenar la última celda de la fila, celda H3

B) Paralelo a esto, la celda B3 me debería dar la fecha y hora exacta de rellenar la última celda de la fila, celda H3.

 

Si me puedes echar (tú o quien sea) otro brazo, lo agradecería de corazón, que esto me tiene de los nervios.

GRACIAS :)

 

PD: He chapuceado A3 con la siguiente fórmula =SI(H3="";"";FILA(A1))

Y con B3 me he llevado un chasco al usar =SI(H3="";"";AHORA())

Edited by Argantonio

Share this post


Link to post
Share on other sites

Mi gozo en un pozo, pero un pozo ni muy hondo. No sé cómo aplicar las propiedades (fórmulas etc) de la fila 3 a las siguientes. He probado lo único lógco que sé: Copiar y pegar y también arrastrar, pero aparecen aberraciones como la de la imagen que adjunto (por ejemplo, Respuesta C pudiendo relacionarse con Sub1 B3

[Sólo la Respuesta B está anidada, en realidad] 

 

Por otra parte, si hay algún modo por el que las filas se vayan numerando solas en la columna A, sería perfecto. Yo utilizo =FILA(), pero lo ideal sería que al rellenar la celda de duración (columna H) aparecieran los números consecutivamente.

Muchas gracias, @bigpetroman

aberración.7z

Share this post


Link to post
Share on other sites

Saludos @Argantonio, el archivo no usa formual para la numeracion, la macro simplemente al realizar el cambio en la columna H automáticamente coloca el siguiente numero en la siguiente linea

prueba a ver, para otras lineas simplemente copia y pega a las siguientes lineas

Saludos

Tablas Anidadas imperfectas.xlsm

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png