Jump to content
Berlin

Formula para detectar Sabados, Domingos y Festivos

Recommended Posts

Buenos tardes.

Estoy intentando crear una tabla que automaticamente me marque qué dias son sabados, domingos y Festivos.

Lo de los Sabados y Domingos, creo que lo tengo con la formula DIASEM, pero me queda detectar los Festivos. Pudiendo ser que algun Festivo
coincida en Sabado.

Espero me podais ayudar. Si no se entiende lo que quiero hacer, lo intentaré explicar mejor.

Adjunto archivo, y gracias por adelantado.

Ayuda Excel.xls

Share this post


Link to post
Share on other sites

Buenas @Berlin

Puedes usar

En celda B3, coloca esta formula

=SI(ESNUMERO(B3);CONCATENAR(SI(CONTAR.SI($K$5:$K$18;B3);"FESTIVO";"");SI(Y(DIASEM(B3;2)>5;CONTAR.SI($K$5:$K$18;B3));" y ";"");SI(DIASEM(B3;2)>5;MAYUSC(TEXTO(B3;"dddd"));""));"")

y luego expande en las celdas necesitadas

En formato condicional

Selecciona las celdas A3:B33

y coloca las siguientes formulas

Festivos:

=Y(ESNUMERO($B3);CONTAR.SI($K$5:$K$18;$B3))

Sábados

=Y(ESNUMERO($B3);DIASEM($B3;2)=6;CONTAR.SI($K$5:$K$18;$B3)=0)

Domingos

=Y(ESNUMERO($B3);DIASEM($B3;2)=7;CONTAR.SI($K$5:$K$18;$B3)=0)

Un saludo

Share this post


Link to post
Share on other sites
Hace 3 horas, Berlin dijo:

pero me queda detectar los Festivos. Pudiendo ser que algun Festivo
coincida en Sabado.

Revisa el adjunto, aplique formato condicional para fines y festivos (solo para Enero)

 

Saludos a todos

Colorear fines y festivos_GP.rar

Share this post


Link to post
Share on other sites

Gracias a todos, pero creo que no me explique bien.

Simplemente quiero que me ponga lo que aparece en la tabla, sin formatos condicionales ni nada.

Subo de nuevo el archivo sin ninguna formula para que se vea exactamente lo que quiero.

Siento haberos echo perder el tiempo por no haberme explicado bien.

Gracias.

 

 

 

 

Ayuda Excel.xls

Share this post


Link to post
Share on other sites
Hace 4 minutos , Berlin dijo:

Gracias a todos, pero creo que no me explique bien.

Simplemente quiero que me ponga lo que aparece en la tabla, sin formatos condicionales ni nada.

Subo de nuevo el archivo sin ninguna formula para que se vea exactamente lo que quiero.

Siento haberos echo perder el tiempo por no haberme explicado bien.

Gracias.

Ayuda Excel.xls

Utiliza esta opcion

=SI(CONTAR.SI($K$5:$K$18,$B3),"Festivo",SI(O(DIASEM(B3,2)=6,DIASEM(B3,2)=7),A3,""))

 

Saludos 

Share this post


Link to post
Share on other sites
Hace 1 hora, Gerson Pineda dijo:

Utiliza esta opcion

=SI(CONTAR.SI($K$5:$K$18,$B3),"Festivo",SI(O(DIASEM(B3,2)=6,DIASEM(B3,2)=7),A3,""))

 

Saludos 

Exacto. Muchiiisimas gracias.

Precisamente queria eso.

Por mi parte se puede cerrar el tema. Por supuesto daros las gracias a todos.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png