Jump to content
lphant

Buscar dato y concatenar con 2 colores

Recommended Posts

Buenos días;

Me podéis ayudar con esto que me ha surgido??.

Tengo 3 hojas Excel “Hoja1/Datos1/Datos2”.

En la “Hoja1” tengo 2 columnas, la columna A es el dato a buscar en las hojas “Datos1/Datos2”, en la columna B quiero que aparezca los datos buscados en las hojas “Datos1/Datos2” concatenados y de diferente color.

Tengo una macro que adjunto en el Excel que concatena 2 columnas de diferente color pero lo que no hace es buscar el dato.

Muchas gracias.

Libro1.xlsm

Share this post


Link to post
Share on other sites

Qué tal @lphant ,

Solo tienes que aplicar la siguiente fórmula siguiente a la celda activa:

=BUSCARV(A2;G1:I8;2)&BUSCARV(A2;G1:I8;3)

Que en VBA sería algo como lo siguiente que tendrías que aplicar a tu código:

busqueda = Application.WorksheetFunction.VLookup(Numero, Range("G1:I8"), 2, False) & Application.WorksheetFunction.VLookup(Numero, Range("G1:I8"), 3, False)

 

Share this post


Link to post
Share on other sites
Hace 25 minutos , Haplox dijo:

Qué tal @lphant ,

Solo tienes que aplicar la siguiente fórmula siguiente a la celda activa:

=BUSCARV(A2;G1:I8;2)&BUSCARV(A2;G1:I8;3)

Que en VBA sería algo como lo siguiente que tendrías que aplicar a tu código:

busqueda = Application.WorksheetFunction.VLookup(Numero, Range("G1:I8"), 2, False) & Application.WorksheetFunction.VLookup(Numero, Range("G1:I8"), 3, False)

 

@Haplox muchisimas garciasss.....ahora mismo lo pruebo.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png