Saltar al contenido
giuli

macro para buscar una fila en una tabla segun combo

Recommended Posts

Tengo una lista de productos que se suman los subtotales y se llega a un total.

Coloque un combo en una celda cuyas opciones son los nombres de clientes que aparecen en otra hoja, al lado de los nombres en dicha hoja esta el total que deben.

Entonces al tener un ticket quiero buscar el nombre seleccionado del combo en la lista de la otra hoja para sumar el total a lo que debe el cliente. ¿Como puedo hacerlo? Les adjunto el fichero

 

Tatiana_2.xlsm

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs
Hace 6 horas, Gerson Pineda dijo:

Hola giuli

No se si entendí, pero con una función, puedo obtener del cliente ese valor, tal que

=SUMA(E5:E27)+BUSCARV(C3,CLIENTES!$B$3:$C$25,2,0)

Sumo con el total la deuda del cliente elegido

¿Era eso?

 

Saludos 

Pero como ejecuto eso dentro de la macro? el boton borra la lista osea limpia las celdas...y luego se haria la suma.

Por otro lado el nombre a buscar esta en C3 pero en la hoja TICKET,hay se lo selecciona. O vos pensas poner el codigo dentro de la hoja TICKET?

Editado el por giuli

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs

Disculpas, no habia visto tus macros, que espero no lo tomes a mal, pero son bastante rudimentarias (tienes que ir mejorando eso, pero eso ya es otro tema)

Con este código podrás obtener, la deuda del cliente

deuda = 0
On Error Resume Next
vf = WorksheetFunction.Match(Range("C3"), Hoja3.Columns("B"), 0)
deuda = Hoja3.Cells(vf, "C")
On Error GoTo 0

Agrégalo a la macro correspondiente

 

Saludos 

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs
Hace 27 minutos , Gerson Pineda dijo:

Disculpas, no habia visto tus macros, que espero no lo tomes a mal, pero son bastante rudimentarias (tienes que ir mejorando eso, pero eso ya es otro tema)

Con este código podrás obtener, la deuda del cliente

deuda = 0
On Error Resume Next
vf = WorksheetFunction.Match(Range("C3"), Hoja3.Columns("B"), 0)
deuda = Hoja3.Cells(vf, "C")
On Error GoTo 0

Agrégalo a la macro correspondiente

 

Saludos 

Gracias por tu ayuda..pero no estas sumando la deuda anterior del cliente con el total del ticket actual:

lo solucione asi:

 

Hoja3.Cells(vf, "C") = Hoja3.Cells(vf, "C") + Range("E28").Value

Funciona a la perfeccion

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs
Invitado
Este tema está cerrado a más respuestas.

×