Jump to content
yameregistre

Validación de Datos no actualiza con nuevas filas, así conviertas el rango en Tabla

Recommended Posts

Buenas con todos

A ver si me pueden ayudar con este pequeño inconveniente con la validación de datos

Si deseo ingresar una lista de nombres en la columna A, siendo A1 el título y de A2:A10 la zona donde se ingresarán los valores pero sin repeticiones

         A

1     Lista

2

3

4

5

6

7

8

9

10

 

Entonces, selecciono de A2:A10 y realizo una validación de datos con fórmula

=CONTAR.SI($A$2:$A$10, A2) =1

Eso me ayuda a que al ingresar nuevos valores, ninguno de ellos esté repetido (al menos dentro de ese rango, de A2:A10)

 

Luego tuve la necesidad de aumentar nuevas filas, entonces convertí todo en Tabla, del rango A1:A10 indicando que A1 era encabezado

 

Pero al ingresar nuevos valores a partir de A11, la Tabla no hace que la validación de datos funcione adecuadamente en A11

Viendo la fórmula en A11 de la validación de datos, veo que queda así:

=CONTAR.SI($A$2:$A$10, A11) =1

Cuando debería estar adaptada como $A$2:$A$11 y no quedarse como $A$2:$A$10

 

Intenté usando el nombre de la Tabla y referencias estructuradas en la Validación de Datos y nada

Intenté usando nombres de rango en la Validación de Datos y nada

 

Cuál es la forma de solucionar esto, para que al ingresar nuevos valores en A11, A12, A13 etc, la validación de datos siga funcionando bien y se adapte a nuevas filas?

Es posible usar referencias estructuradas o rangos con nombres para solucionar esto?

Sería la única solución que el Contar.Si lleve como rango A:A y luego convertir todo en Tabla y así tenerlo de forma automatizada para las nuevas filas con datos que se agreguen debajo de A10?

 

Saludos!

 

 

Lista sin repetidos.xlsx

Share this post


Link to post
Share on other sites
Hace 4 horas, yameregistre dijo:

con la validación de datos... ingresar una lista... en la columna A, siendo A1 el título y de A2:A10 la zona ...

... convertí todo en Tabla, del rango A1:A10 indicando que A1 era encabezado... la Tabla no hace que la validación de datos funcione adecuadamente en A11 ...

Intenté usando el nombre de la Tabla y referencias estructuradas en la Validación de Datos y nada

Intenté usando nombres de rango en la Validación de Datos y nada

el detalle es que las tablas (antes listas) son un objeto que se cuece aparte, desde que usan referencias estructuradas en lugar de simples referencias a celdas y rangos y a partir de ello, para poder usar tablas en reglas de validación "sobre ellas mismas", necesitas "pasar" por un nombre-definido que haga referencia a "la tabla" (me explico)

suponiendo que tu tabla se llama "Tabla1" y que su titulo es "Lista"

1) define un nombre (p.ej. miTabla) con referencia a: =tabla1[lista]
2) selecciona el rango de la tabla (sin el encabezado)
3) en las reglas de validación (personalizada) aplica una formula +/- como esta: =contar.si(milista,a2)=1

esto suponiendo que el primer elemento de Tabla1 va a estar en la celda [A2]
y OJO con el separador de argumentos, mi sistema usa a la coma

saludos,
hector.

Share this post


Link to post
Share on other sites
Hace 14 horas, Héctor Miguel dijo:

1) define un nombre (p.ej. miTabla) con referencia a: =tabla1[lista]

Puede ser porque en este primero paso lo hiciste incorrectamente, lógicamente debes tener un archivo con una BD en formato de TABLA, que se llame Tabla1 y que el titulo sea "Lista"

Mejor revisa el adjunto

 

Saludos

Lista sin repetidos.xlsx

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png