Saltar al contenido
yameregistre

Filtrar superiores e inferiores con empates

Recommended Posts

Hola con todos

 

Si tengo una lista de valores ejemplo

Venta

55
55
55
55
55
55
56
57
58
59
60
60
61
62
63
64
64

 

si Intento un filtro con la opción 5 inferiores
Lo que esperamos seria tener 55, 56, 57, 58 y 59

 

Pero el resultado sólo muestra todas las repeticiones de 55

 

55
55
55
55
55
55
 

 

Cómo solucionan o lidian con este tipo de casos?

Yo tuve que hacer una columna auxiliar y un contar.si que me permita tener sólo una vez cada elemento

Se soluciona de otra manera? Existe alguna opción especial?

Gracias, saludos

 

FILTRAR CUANDO HAY EMPATES.xlsx

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs

Amigo Snake, la pregunta es sobre cuando uno filtra los "x" superiores e inferiores, y no sobre tener la lista de únicos

Ejemplo 

Tienes

10
10
20
20
30

Quiero los dos más bajos

 

Usando filtro, 2 inferiores, la respuesta obtenida es:

10
10

 

Y lo que se esperaría tener por resultado en realidad debe ser:
10
20

 

 

 

La solución de Silvia es buena, pero tiene el problema de que deben ser números  que estén ordenados para que funcione, del tipo

3
3
3
4
7
8

 

Es decir, si tengo

Ventas

3
7
3
4
8
3

Y quiero filtrar los dos inferiores, su fórmula no funcionaría

 

 

Y la pregunta también de si obligatoriamente tendría que usar una columna auxiliar cuando existen empates y quiero filtrar los x superiores/ inferiores, o existe alguna solución adicional

 

Saludos

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs

Pues, en mi caso, la solución se da de acuerdo a la consulta.....

si tienes los datos desordenados, puedes utilizar

=CONTAR.SI($A$5:A5,A5)

** mi separador de argumentos es la coma, si el tuyo es otro, corriges.

 

Hace 15 minutos , yameregistre dijo:

Y la pregunta también de si obligatoriamente tendría que usar una columna auxiliar cuando existen empates y quiero filtrar los x superiores/ inferiores, o existe alguna solución adicional

 

la otra opción es que elimines los duplicados desde la ficha Datos/ quitar Duplicados

 

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs
Hola Silvia

=CONTAR.SI($A$5:A5,A5) es la solución que yo mismo pongo en mi archivo original

Yo usé =SI(CONTAR.SI($A$5:A5,A5)=1, A5, "")

 

La pregunta de mi tema va por dos puntos:

 

- Hay otra forma de hacerlo además de crear una columna auxiliar con fórmula?

Una respuesta es quitar duplicados como bien comentas

 

- Si se usa fórmulas en una columna auxiliar, si hay otra opción a:

=SI(CONTAR.SI($A$5:A5,A5)=1, A5, "")

 

Saludos

:)

 

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs

Es posible usar el Power Query, pero  los registros quedarian en una tabla aparte de los datos originales.

Aunque si lo que se quiere es lograr algunos calculos sobre campos numericos que acompañen a esos "menores", por ejemplo sumar los 5 menores, o algo así, se podria completar el modelo.

Saludos,

Filtrar menores con Power Query.xlsm

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs

Pasos Power Query

let
    Origen = Excel.CurrentWorkbook(){[Name="Tabla1"]}[Content],
    #"Columnas quitadas" = Table.RemoveColumns(Origen,{"Provincia", "cliente"}),
    #"Duplicados quitados" = Table.Distinct(#"Columnas quitadas"),
    #"Filas ordenadas" = Table.Sort(#"Duplicados quitados",{{"Valor", Order.Ascending}}),
    #"Índice agregado" = Table.AddIndexColumn(#"Filas ordenadas", "Índice", 1, 1),
    #"Filas filtradas" = Table.SelectRows(#"Índice agregado", each [Índice] <= 5),
    #"Columnas quitadas1" = Table.RemoveColumns(#"Filas filtradas",{"Índice"}),
    #"Columnas con nombre cambiado" = Table.RenameColumns(#"Columnas quitadas1",{{"Valor", "MENORES"}})
in
    #"Columnas con nombre cambiado"

 

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs

** Hola a todos..

Yameregistre,

Para  cambiar de filtro, (y no estar entrando al filtro para quitar el filtro previo), es más rápido, seleccionar A4:B4 y ejecutar Control+Shift+L dos veces.. con una quitas el filtro y con la otra vuelves a colocar los filtros, recién ahí filtras por color.. en A4 o en B4, según tu necesidad...

** @GabrielRaigosa  Maestro, algunas veces ya no puedo dejar de utilizar los atajos (solo los que aprendí)..., todo por su culpa..  <_< :P:D:wub: 

 

Compartir este mensaje


Enlace a mensaje
Compartir con otras webs
Invitado
Este tema está cerrado a más respuestas.

×