Jump to content
sprit36

Suma y resta condicional

Recommended Posts

Hola @sprit36

Mi separador de Argumentos es ",", tal vez el tuyo es ";" pero date cuenta que las respuestas te llevan al mismo resultado, solo es un poco mas como lo indica @Mauricio_ODN

Hace 13 minutos , Mauricio_ODN dijo:

tu hubieras podido modificarlo

Yo corrobore ambas respuesta tanto la de el como la mia y funcionan, solo tienes que hechar a volar tu imaginación, no solo estas pueden ser las respuestas, hay un sin fin de posibilidades

Saludos Amigos !!!

Share this post


Link to post
Share on other sites

Gracias por vuestras respuestas, he probado a cambiar la fórmula y he conseguido lo que busco, lo único que me sale el resultado en negativo.

=SI(A13>=0;B13;SI(A13<0;-B13-A13))

¿Como puedo hacer para evitarlo?

Gracias. 

Share this post


Link to post
Share on other sites

Gracias, pero no funciona en los negativos sale mal el resultado.

 esta es la fórmula que funciona bien salvo lo de cero que sale en negativo. 

=SI(A13>=0;B13;SI(A13<0;-B13-A13))*-1

Share this post


Link to post
Share on other sites

Hola y si usas la funciona =ABS  , es una función que devuelve el numero absoluto seria algo asi:

=abs(SI(A13>=0;B13;SI(A13<0;-B13-A13)))

Saludos

 

Share this post


Link to post
Share on other sites

Mauricio, siento lo del archivo, pero tengo problemas con el teléfono para adjuntar archivos, lo sé que es más fácil con archivo. Estoy muy agradecido a todos por su ayuda. Gracias! 

Share this post


Link to post
Share on other sites
Hace 7 minutos , sprit36 dijo:

Mauricio, siento lo del archivo, pero tengo problemas con el teléfono para adjuntar archivos, lo sé que es más fácil con archivo. Estoy muy agradecido a todos por su ayuda. Gracias! 

Lo importante es que lograste Solucionar el problema!! Seguimos a tus Ordenes, Saludos y buena Tarde!!!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Moderar y responder comentarios de usuarios. Recuerda que la información que facilites es pública, y los datos que incluyas los leerá cualquier visitante de esta web, así como el avatar que poseas.

Legitimación: Consentimiento del interesado.

Destinatarios: Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.




  • Posts

    • Hola buenas tardes amigos de Ayuda Excel Estoy parado en una macro que no he podido resolver a ver si pueden ayudarme. Gracias de antemano por su colaboración. Les explico. El archivo tiene varias hojas, Una se llama control enero, control febrero y asi sucesivamente La macro la voy a ejecutar en cada hoja Lo que debe hacer la macro es: 1)      copiar la celda A3, que es una formula, de la Hoja CONTROL 1  a la primera fila disponible de la columna A5 de la Hoja Control General. 2)      Copiar la celda j22 de Control 1 (que es una formula), como valor sin negrita a la primera fila disponible de F5 de la Hoja Control general. 3)      Hacer una botón para ejecutar la macro, teniendo en cuenta que solo debe ejecutarse si la celda j25 de la Hoja Control 1 es igual a SI. Por el contrario si es igual a NO, no debe permitir la ejecución de la macro. Pudiera ser advertido al usuario mediante un MSGBOX. 4)      Por último la posición de las celdas J22 y j25 pueden variar de hoja a hoja según la información introducida en cada hoja. Agradecidos de antemano por la colaboración prestada. LB Anexo archivo CONTROL GENERAL.xlsm
    • Un nuevo aporte para finalizar el proyecto Tengo el archivo funcionando cuando el usuario requiere solo una hoja activa. cuando se requiere que mas hojas estén activas no funciona. Ejemplo el user marco pass 123 debería tener activas las hojas "Registro, Registro1, Registro2". Con el codigo actual solo funciona la hoja "Registro" Ademas un favor extra que dependiendo el usuario que inicie sección ponga el Nombre de la columna "Nombre" en ("01.Adeudos" tabla "usuarios") del archivo en ACCESS y lo pegue en la hoja "Principal" celda C7 del archivo de EXCEL. en el siguiente enlace esta un ejemplo del proyecto. https://mega.nz/file/YRpRXZTL#Uynlq0oW77Eo0VbME26yYkKc1g7jXXu9w1AwfbFlRp0 De nuevo muchas gracias por toda la ayuda en el proyecto. Saludos
    • Hola buenas tardes amigos de Ayuda Excel. Quería preguntar si hay alguna manera de copiar y pegar una celda que tiene un prefijo en otra celda pero que el prefijo APAREZCA en la barra de fórmula. Gracias
    • Todo en la misma hoja.   Filtro Antoni.xlsm
    • Hola @Persal95 Una posible solución, Espero que sea de utilidad. Nos comentas.EJEMPLO AYUDA EXCEL 1.1.xlsx
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy