Jump to content

Archived

This topic is now archived and is closed to further replies.

AUGUSTO VARGAS

Buscar valor de la ultima fecha de actualizacion

Recommended Posts

Saludos experto

Esta ves vengo con un nuevo tema; estoy usando esta formula  =SUMAPRODUCTO(MAX((D4:D12=B3)*(I4:I12=B4)*F4:F12)) para buscar la valor máximo de una tabla de precio..

La formula que uso me da las siguientes información:

D4:D12=B3 ( me busca el código del producto)

I4:I12=B4 ( me busca el nombre del proveedor)

F4:F12 ( me busca el valor mas alto)

Nota: lo que Necesito es que la formula me diga cual es el ultimo valor según la ultima fecha de actualización.

 

En la espera de su acostumbrada colaboración

Se despide.

A.V.

Prueba.xlsx

Share this post


Link to post
Share on other sites

hola a todos..

a ver que le encontrarán a la mía.. :P

=INDICE(F4:F12,MAX(INDICE((I4:I12=B4)*(D4:D12=B3)*FILA(E4:E12),))-3)

mi separador de argumentos es ";", corregir en caso de ser necesario..

**Gerson, en caso que se coloque un valor que no existe, tu formula siempre da un resultado..  :D

 

saludos,

Silvia

 

Share this post


Link to post
Share on other sites

Hola a tod@s, @Silvia tu fórmula adolece de lo mismo que la mía. Si hay dos fechas iguales elige la primera y no la cantidad mayor de las dos celdas con fecha igual (si es que es así como parece)

@Gerson Pineda si cambio la referencia de B4, por ejemplo poniendo 5, tu fórmula no me da el resultado correcto que es 12000 Bsf...

Saludos,

bfelix

Share this post


Link to post
Share on other sites
Hace 38 minutos , bfelix dijo:

no la cantidad mayor de las dos celdas con fecha igual

uy  :o ,   recién leo bien eso.... osea se la cantidad mayor entre las fechas iguales?? así lo pidió? vaya que enrredo..

en todo caso, ya tiene de donde escoger la que mas le conviene..

;)

 

Share this post


Link to post
Share on other sites

Cuanta razón tienen @Silvia @bfelix :D con un ajuste, creo que ahora si funciona (desde luego falta mejor explicación del consultante)

Hace 1 hora, Silvia dijo:

 

hola a todos..

a ver que le encontrarán a la mía.. :P

 

La tuya no toma en cuenta las fechas!

 

Saludos a todos 

 

Obtener cantidad segun fecha reciente_GP.rar

Share this post


Link to post
Share on other sites
Hace 1 hora, bfelix dijo:

Hola a tod@s, ahora si. Trabajada la formulita @Gerson Pineda...

Saludos,

bfelix

 

y como dice Silvia, es posible que las fechas no sean necesarias a tomarlas en cuenta, pues se supone que por cada año, solo "habrá" una fecha, siendo asi la formula, se agrega la función FILA

=SI.ERROR(SI(COINCIDIR(B3&B4,INDICE(D4:D12&I4:I12,),),INDICE(F4:F12,INDICE(COINCIDIR(MAX((D4:D12=B3)*(I4:I12=B4)*(FILA(I4:I12)-3)),(D4:D12=B3)*(I4:I12=B4)*(FILA(I4:I12)-3),),),)),"NO EXISTE")

Saludos @bfelix 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Moderar y responder comentarios de usuarios. Recuerda que la información que facilites es pública, y los datos que incluyas los leerá cualquier visitante de esta web, así como el avatar que poseas.

Legitimación: Consentimiento del interesado.

Destinatarios: Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.




×
×
  • Create New...

Important Information

Privacy Policy