Jump to content

Archived

This topic is now archived and is closed to further replies.

vecodis

Celda con resultado exponencial

Recommended Posts

hola vecodis

a veces excel tiene sus cosas raras...

he probado utilizando la función redondear a 2 decimales, en las columnas k y J, y se soluciona ...

pruebas y comentas si es lo que necesitas..

saludos,

Silvia

Share this post


Link to post
Share on other sites

Hola vecodis (gusto en saludarte [uSER=52414]@Silvia[/uSER]), el resultado que obtienes es un problema que afecta a TODOS los aparatos de cálculo electrónico (calculadoras y computadoras) aunque puede haber un comportamiento diferente, pero afecta a todos. Si buscas por Internet punto flotante, o coma flotante, encontrarás mucha información sobre el tema. Responde a la norma IEEE 754.

De forma resumida (y un poco torpe) el problema se produce porque las máquinas electrónicas de cálculo convierten los números con base decimal (los que utilizamos) en base 2 o binaria. Las máquinas utilizan un número determinado de dígitos y con ellos NO pueden representar TODOS los números con decimales (a nosotros en cálculo decimal nos ocurre lo mismo, piensa en el resultado de 1/3...) cuando un número no se puede representar lo redondea al más próximo (que es tu caso).

En general no lo apreciamos porque el redondeo afecta a un decimal de orden muy bajo (el tuyo es el decimal 14) y no afecta a los cálculos comunes, pero a veces lo vemos.

Por eso [uSER=52414]@Silvia[/uSER] elimina el problema al redondear, y no afectará al resultado final.

¿Cuando es muy peligroso? Cuando el resultado sirve para tomar una decisión (con la función SI, por ejemplo) En tu caso si le pides que =SI(A2=0) debería dar VERDADERO y te dará FALSO... Habrías de redondear a la cifra decimal 8 (es un decir) y sin afectar al cálculo te daría el resultado esperado.

Saludos,

bfelix

Share this post


Link to post
Share on other sites

Hola vecodis, mientras aparece [uSER=52414]@Silvia[/uSER], en la columna K (celda K2) pon =REDONDEAR(tu_formula);2) Yo utilizo el ";" como separardor de decimales si no es el tuyo lo has de cambiar.

Copia hacia abajo. Problema resuelto. Pero no estaría de más seguir su consejo y hacer lo mismo con la columa J.

Saludos,

bfelix

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Moderar y responder comentarios de usuarios. Recuerda que la información que facilites es pública, y los datos que incluyas los leerá cualquier visitante de esta web, así como el avatar que poseas.

Legitimación: Consentimiento del interesado.

Destinatarios: Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.




  • Posts

    • Hola, simplemente poniendo en la variable filas un valor superior a la columna con mas datos Libro10.xlsm
    • Pues esto no me lo esperaba... . Investigando parece una especie de bug de Excel y el evento Calculate. La verdad es que cada vez que he lidiado con este evento me ha dado más quebraderos de cabeza que otra cosa. Te dejo otra solución. Prueba y me dices BUSCAR DATO EN OTRA HOJA-1.xlsm
    • Gracias por responder, avalencia lo único que quiero es de la variable "fecha" sacar el numero de semana.   JSDJSD seria posible sacar la semana de los datos que tengo puesto en la hoja de excel y no desde un formulario, he visto otros ejemplo de formulario, pero la verdad que no llego a enterarme del código para sacar el numero de semana, de todas formas es de ahí donde tengo que obtener el año y el mes.   P.D. En el ejemplo solo funciona con enero y febrero, cuando la primera semana empieza en sábado o miércoles, el resto no esta completo el código.  
    • Hola @Haplox buenos días. Tengo una consulta. Si bien la macro funciona perfectamente. Ahora cada vez que abro un archivo excel, teniendo abierto el archivo donde está la última macro que enviaste, sale en mensaje que dice "Se ha producido el erro '9' en tiempo de ejecución. Subindice fuera del intervalo" Que será???
    • buenas; De entrada, gracias por responder, y tan rápido!! Acabo de probar el excel que me enviastes, pero no es exactamente lo que busco; Me explico; el tema es que cualquiera de estas entradas: tu2 TU02 TU 02 TU-02 TU-2 me dé como resultado todos estos archivos: A -TU2 - - Rev_0.pdf A -TU02 - - Rev_0.pdf A -TU 2 - - Rev_0.pdf A -TU-02 - - Rev_0.pdf pero no estos: A_TU_12--Rev_0.pdf A_TU 22--rev_0.pdf  Las entradas se escriben a mano, y cada uno la escribe como le da la gana los planos nos los dan, y también cada obra numera distinto; pero, en este ejemplo, todas las entradas apuntan a la pieza "TU 2", y busco que todos los planos que apunten a esa pieza los encuentre, pero los que apunten a la pieza, "TU 12" o "TU 22" p.ej. no salgan como resultado
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy