Jump to content

Sumar 1 al numero anterior (contador)


lphant

Recommended Posts

Buenas chic@s;

estoy intentando crear un contador que me sume 1 al numero anterior (la celda contiene texto y numero), con formulas lo he conseguido si siempre es el mismo formato (con la función extraer (extraigo el numero) y luego la función contar), pero eso no me vale para la macro que tengo, puede haber entremedias celdas con otro formato que no debe de contar, las celdas a contar son las que empiezan por Cajaxx.

se os ocurre como hacerlo??.

Muchisimas gracias.

contador.xls

Link to post
Share on other sites
Buenas chic@s;

estoy intentando crear un contador que me sume 1 al numero anterior (la celda contiene texto y numero), con formulas lo he conseguido si siempre es el mismo formato (con la función extraer (extraigo el numero) y luego la función contar), pero eso no me vale para la macro que tengo, puede haber entremedias celdas con otro formato que no debe de contar, las celdas a contar son las que empiezan por Cajaxx.

se os ocurre como hacerlo??.

Muchisimas gracias.

Hola

Excel ya nos regala esa funcion, pegala en la celda c1 por ejemplo y la copias hacia abajo

=SI(IZQUIERDA(B2,4)="Caja",CONTAR.SI($B$2:B2,"Caja*"),"")[/CODE]

Puede ser que el separador de argumentos de tu formula sea ;

Saludos

Link to post
Share on other sites

Pon esta código en un módulo y ejecuta la macro Sumar:



Function Añadir1(Cadena As Variant) As Variant
If IsNumeric(Cadena) = True Then
Añadir1 = CLng(Cadena) + 1
Exit Function
End If
For x = 1 To Len(Cadena)
If IsNumeric(Mid(Cadena, x, 1)) = True And _
Not Mid(Cadena, x, 1) = "0" Then
Añadir1 = Left(Cadena, x - 1) & CLng(Mid(Cadena, x)) + 1
Exit Function
End If
Next
End Function

Sub Sumar()
Range("B5") = Añadir1(Range("B5"))
End Sub

[/CODE]

Esta función vale para cualquier combinación de numeración con el formato:

[b]Parte alfabética+parte numérica.

[/b]

Respeta los ceros a la izquierda del primer dígito significativo de la parte numérica.

_

Link to post
Share on other sites

Muchísimas gracias a los 2.

Gerson, la formula no me vale para lo que estoy haciendo pero se agradece.

Macro Antonio, me has vuelto a salvar jejejeee.....he conseguido adaptar el código que has pasado en mi macro, te lo agradezco muchísimo.

Pd: nunca he sabido como se cierra los temas.

Un saludo,

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Privacy Policy