Jump to content
Sign in to follow this  
Salvador1

Asignar mismo nº a celdas que contengan mismo nombre incluido en medio de un texto, y ordenar.

Recommended Posts

Hola:

La consulta trata de simplificar la fórmula del adjunto.

Básicamente se trata de asignar un número (1, 2, ...) a las celdas que contengan el mismo nombre, los cuales están contenidos dentro de un texto en cada celda (si no, hubiera servido un simple BuscarV), y para ello he usado:

SI(CONTAR.SI(D2;"*"&$A$2&"*")>0;1;SI(CONTAR.SI(D2;"*"&$A$3&"*")>0;2;...

Yo propongo usar un sumaproducto (parecido a lo de abajo), pero no sé como decirle que "si contiene..."

sumaproducto((A2:A14)contiene(d2:d14)*B2:B14)

Asignar nº empresas.rar

Share this post


Link to post
Share on other sites

Hola.

No llegue a entender muy bien el valor que quieres que aparezca sino se encuentra una coincidencia, pero de momento prueba esta formula y di si van por hay los tiros.

=SI(ESERROR(COINCIDIR(EXTRAE(ESPACIOS(D2);ENCONTRAR(" ";ESPACIOS(D2))+1;255);A$2:A$15;0));FILA()-1;1)

Saludos.

Share this post


Link to post
Share on other sites

Intentaré explicarme mejor:

Quiero que me aparezcan los mismos valores que hay ahora en la columna E, pero con una fórmula más sencilla. Para eso he propuesto un suma producto utilizando las columnas A, B y D.

La idea es ordenar la lista de empresas (colum. D) por nombre. Pero no se puede usar la herramienta Ordenar porque cada nombre tiene texto a su derecha e izquierda (ej: 53393 SACYR 15000...En el archivo le he borrado el texto de su derecha). Por eso he utilizado CONTAR.SI con asteriscos.

Se trata de que todas las empresas que se llamen "Sacyr" se le asigne un mismo número (ej. 1), todas las de "Instal" un 2 (mismo orden que en la columna A), etc. para que al final pueda ordenar esa columna de números (col.E) y queden -como en la col. J- todos los "Sacyr" juntos, todos los "Instal" juntos, etc.

No sé si te aclaro o te lío más. :joyous:

Saludos.

Share this post


Link to post
Share on other sites

Hola.

Con esta formula:

=COINCIDIR(EXTRAE(ESPACIOS(D2);ENCONTRAR(" ";ESPACIOS(D2))+1;255);A$2:A$15;0)

Te asigna el numero de fila que tienes en la columna B, pero si no encuentra te marca error.

Cuando no encuentre la coincidencia que resultado tendria que devolver la formula?

Saludos.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png