Jump to content
Sign in to follow this  
Danielr

Autocompletar lista validación de datos

Recommended Posts

Hola a todos,

En el archivo adjunto tengo creada una lista con la referencia de unos productos, cuando inserto en la celda que se encuentra en ROJO, quisiera que se me autocompletara o me sacara coincidencias con la lista que existe, me han dicho que es mediante el uso de visual, pero la verdad no tengo la mas mínima idea.

Muchas gracias.

Adjunto el archivo.

Libro2.zip

Share this post


Link to post
Share on other sites

Hola Manolo,

Muchas gracias, quedo excelente.

Una pregunta: una vez seleccione una referencia, como hago para que en la celda inferior a esa ocurra el mismo procedimiento, es decir que seleccione otra referencia y quede en esa celda, y asi sucesivamente???

Share this post


Link to post
Share on other sites

con un bucle

un for serviria

para cada vez que se seleccione cambie a la siguiente celda pero no se que objetivo tiene o a lo menor no te entendí, envíame el archivo con lo que deseas y lo revisamos.

Share this post


Link to post
Share on other sites

Saludos.

Una opción sin macros usando listas validadas.

Se utlizan dos formulas una al nombrar rango y otra para la lista validada.

Nombrar rango:

Nombre rango: VINOS

Formula:

[COLOR="#0000FF"]=DESREF(Datos!$A$1,0,0,CONTARA(Datos!$A:$A),CONTARA(Datos!$1:$1))[/COLOR][/CODE]

Lista validada:

1.-En permitir seleccionar opción Lista.

2.-En Origen la siguiente formula:

[CODE][COLOR="#0000FF"]=INDICE(VINOS,COINCIDIR(B2&"*",VINOS,)):INDICE(VINOS,COINCIDIR(B2&"*",VINOS,)+CONTAR.SI(VINOS,B2&"*")-1)[/COLOR][/CODE]

3.-En mensaje de entrada deseleccionar casilla.

4.-En mensaje de error deselecionar casilla.

5.-Aceptar.

Uso:

1.-Intruduces en la celda donde esta la lista la letra incial de la consulta.

2.-Click en la flecha para desplegar la lista, solo te apareceran los items que inicien con la letra que indicaste.

3.-Para tener la misma lista en otras celdas pues solo arrastra y listo.

Pruebalo y veras que tiene una versatilidad muy buena.

Atte.

joshua

Lista.zip

Share this post


Link to post
Share on other sites

La verdad lo de josua me pareció muy bueno, cambie para que no se vean las listas, lo cambie un poco, no diciendo que me gusta, pero lo único que no vi factible es que si no recuerdas muy bien algún dato que quieras escoger se te complica si escribo chandon no tengo respuesta por que solo busca si la ingreso bien desde el principio.

Lista.zip

Share this post


Link to post
Share on other sites

Hola Manolo,

Perdón la demora en responder, te adjunto el archivo con la Versión 2, aca vas a ver varia celdas en ROJO, basicamente lo que me gustaria es que cada vez que completo una celda con el nombre de la lista, automaticamente pase a la siguiente celda que esta en ROJO y colocar ahí otra referencia.

Lo que busco es que en esa semana pueda ver todas las referencias que se vendieron.

Gracias!!!

Lista2.rar

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 6254 personas - Aprender Excel - Total: 4.7 / 5