Jump to content
Sign in to follow this  
Argantonio

Recoger información de una tabla según varios parámetros.

Recommended Posts

Muy buenas, caballeros:

Imaginen que he de llevar una tabla de seguimiento de unos alumnos.

Hasta el momento, sólo tenía que seguir los cursos con número “1,2,3….” Con el expediente A.

Ahora, hay un nuevo expediente, el B con cursos del mismo número “1,2,3,4…”

No descartamos que aparezcan expedientes C,D,E…

Necesito que por separado (en la misma hoja), pueda obtener la información de ambos expedientes con sus cursos… ¿También puede ser obtener esto en la misma tabla?

Adjunto veréis el intento lo que llevo adelantado (gracias a más de uno de aquí).

Lo ideal debería ser ACCESS, pero aún...

Espero que me podáis ayudar, ya que estoy bastante confuso.

:mad:

Mil millones de gracias.

:welcoming:

Seguimiento cursos.zip

Share this post


Link to post
Share on other sites

Hola Argantonio, perdona pero después de ver tu archivo y al parecer 6 más, no he entendido nada de lo que quieres, solo se ven las tablas que utilizas pero no explicas qué haces y qué necesitas, así que como no expliques mejor ambas cosas, incluso no vendría bien que marcaras en ella de donde extraer y donde poner tus necesidades.

Saludos, Germán.

Share this post


Link to post
Share on other sites

Buenas, Germán.

Esto es una tabla en la que registro informaciones de cursos.

Cadacurso tiene asignado un número y una letra (expediente, o, EXP).

Antes sólo había un expediente, el A.

Los datos se meten en el cuadro de abajo, y se reflejan en el de arriba (cualquiera de los dos, en realidad)

Necesito, en resumen, que el cuadro de arriba distinga que los cursos (intriducidos en columna C) sean de un expediente distinto (introducidos en la columna B)

Claro, el problema viene de que siendo expediente B, puede ser curso 5, 9, 8... PERO 5, 9, 8 pueden ser de A también.

Más resumido. El cuadro de datos de arriba, no distingue Expedientes, sólo cursos.

:peach:

Gracias por el interés, Germán.

:tranquillity:

Share this post


Link to post
Share on other sites

Hola Argantonio, pues no sé si me ha quedado claro, pero bueno te he preparado un ejemplo de lo que he entendido, he añadido una columna más y en ella lo que he hecho es concatenar los EXP con los cursos, así las búsquedas siempre las hace individuales porque los resultados son únicos, echa un vistazo para ver si te sirve, incluso luego si quieres puedes ocultar esa columna, ya que no cambiará en su resultado, luego comenta algo, ok?

Saludos, Germán.

Seguimiento cursos_VG.zip

Share this post


Link to post
Share on other sites

Ufff... no recordaba el uso de &

Te lo agradezco.

Me pregunto si hay una fórmula que unida a las que ya están en la tabla de resultados, evite una nueva abrir columna.

Te lo agradezco al 100%

GRACIAS :applouse::applouse:

Share this post


Link to post
Share on other sites

Buenas de nuevo, Germán

Tu solución me gusta.

PERO me gustaría saber si hay posibilidad de evitar esa columna con = &

Fíjate que todas los sumaproducto tienen como referencia la columna CURSO nada más.

Lo ideal sería que tuvieran como referencia a CURSO y EXP (columnas B y C del archivo que me mandas).

GRACIAS

GRACIAS :)

Share this post


Link to post
Share on other sites

Hola Argantonio

Puedes probar a eliminar la columna C y a usar


=SUMAPRODUCTO(($B$21:$B$32=$A4)*($B$21:$B$32<>"")*($C$21:$C$32=$B4)*($C$21:$C$32<>""))[/CODE]

aunque con

[CODE]
=SUMAPRODUCTO(($B$21:$B$32=$A4)*($B$21:$B$32<>"")*($C$21:$C$32=$B4))[/CODE]

también podría valerte.

Un saludo desde Vitoria (hoy más fría y gélida de lo habitual)

Share this post


Link to post
Share on other sites
Hola Argantonio

Puedes probar a eliminar la columna C y a usar


=SUMAPRODUCTO(($B$21:$B$32=$A4)*($B$21:$B$32<>"")*($C$21:$C$32=$B4)*($C$21:$C$32<>""))[/CODE]

aunque con

[CODE]
=SUMAPRODUCTO(($B$21:$B$32=$A4)*($B$21:$B$32<>"")*($C$21:$C$32=$B4))[/CODE]

GRACIAS, Ioyama...

Es el tipo de solución que buscaba... sin embargo no sé ponerla en mi tabla... :(

Anidar fórmulas y yo no somos compatibles aún :apologetic:

Sorry

:/

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png