Jump to content
Sign in to follow this  
pcourtois

Contar.si. Es mayor que y menor que

Recommended Posts

Guest Cacho R

Hola! pcourtois.

Complementando lo mencionado por Gerson (a quien le envío un gran saludo), tienes dos opciones:

a) Le envías a los ingenieros de Microsoft una nota pidiéndoles que la función CONTAR.SI haga una cosa distinta de aquello para lo que fue diseñada; o

B) Buscas opciones. Una de ellas ya te la menciona Gerson. Otra variante es:

= SUMAPRODUCTO( ($A$1:$A$10 >= 4) * ($A$1:$A$10 < 6) )[/CODE]

Saludos, Cacho R.

Share this post


Link to post
Share on other sites

Hola pcourtois

Puedes usaar la función "Sumaproducto":

Si los datos están en el rango A1:A15

=SUMAPRODUCTO((A1:A15>=4)*(A1:A15<6)*1)

Si solo se puede usar la función "Contar.Si" ,a ver si te puede servir así:

=(CONTAR.SI(A1:A15;">4")+CONTAR.SI(A1:A15;"<5"))-(CONTAR.SI(A1:A15;"<4")+CONTAR.SI(A1:A15;">5"))

Share this post


Link to post
Share on other sites
Guest Cacho R

¡Pero Gerson!...

A1:A10 (rango por ti propuesto) no son millones de celdas...

¡Te lo aseguro!... ¡Créeme!... (jejejeje)

Share this post


Link to post
Share on other sites

jeje es correcto, pero solo es para un ejemplo, (pcourtois debe adjuntar uno), pues no sabemos que cantidad de datos va a leer con las formulas, me entiendes? siempre pensando un poco en cantidades grandes de datos, recuerda que aqui solo se solicita un fragmento

Saludos

Share this post


Link to post
Share on other sites
Guest Cacho R
jeje es correcto, pero solo es para un ejemplo, (pcourtois debe adjuntar uno), pues no sabemos que cantidad de datos va a leer con las formulas, me entiendes? siempre pensando un poco en cantidades grandes de datos, recuerda que aqui solo se solicita un fragmento

Saludos

Mi estimado Gerson

Por ser vos te doy un 50% y 50%... O sea:

a) Es cierto que pcourtois no dio referencia alguna sobre la cantidad de datos sobre los que desea operar. Pero...

B) Eso de "... grandes cantidades de datos ..." me suena inconsistente con la permanente prédica sobre que si se manejan grandes cantidades de datos, entonces lo que conviene es trabajar con bases de datos y no con Excel, aún si de la versión 2010 habláramos...

Esto es como quien tiene un Fiat 600 y te dice: - " Le bajé la suspensión y me dio 132 km/h en ruta "...

¿No lo crees?...

Saludos, Cacho R.

Share this post


Link to post
Share on other sites
Guest Cacho R

Gerson:

Te propongo que si pcourtois no nos brindara su parecer en el transcurso de las siguientes doce horas, sigamos hablando de automóviles antigüos... ¿Qué tal?.

Share this post


Link to post
Share on other sites

Gracias a todos por su siempre acostumbrada atención a los temas.

Es correcta la observación de que no coloqué rango, será una columna completa, por decir $A$A$, ya que puede contener quince celdas con datos o pudieran ser las 1048576 celdas de Excel 2007.

No había respondido porque la tabla la tengo en la oficina y actualmente estoy en mi casa, pero mañana les comento como me fue, lo mas seguro es que utilicé el aporte del amigo Gerson =CONTAR.SI($A$1:$A$10,5)+CONTAR.SI($A$1:$A$10,4) es el que mas se me asemeja a lo que busco.

A todos Gracias por sus aportes, eso es lo que nos destaca como comunidad dentro de la red, la participación siempre oportuna.

Saludos

--- Mensaje unido automáticamente ---

Definitivamente es esa la opción Gerson.

Muchas Gracias y saludos a todos

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 5112 personas - Aprender Excel - Total: 4.7 / 5