Jump to content

[SOLUCIONADO] Suma por referencia en dos hojas


sprit36

Recommended Posts

Hola a todos:

Tengo una duda, adjunto un ejemplo en el cual tengo por un lado en una hoja unos datos, en el ejemplo he puesto unos cuantos pero tengo muchos mas. Necesito una formula que en base a la referencia que es SS1, SS2 y SS3 sume de la Hoja2 el nº de articulos vendidos y por otra parte el nº de articulos no vendidos y pedidos.

Gracias.

Un saludo

Ejemplo1.zip

Link to comment
Share on other sites

Re: Suma por referencia en dos hojas

Gracias Sebastian, en la primera columna funciona perfectamente, donde no me queda muy claro es en la segunda, creo que la formula de la primera esta bien es:

=SUMAPRODUCTO((Hoja2!$B$2:$B$6="SS1")*Hoja2!$C$2:$C$6*(Hoja2!$F$2:$F$6=E2))

En donde dice: ="SS1") aqui quizas deberia ser ="SS1" ¨SS2¨¨SS3¨ para que busque esos valores, pero no sé si es posible ya que lo intento y me dá error en la formula.

Por otra parte como seria la formula para que buscar la referencia SS1 y que sume los vendidos y pedidos de la tienda 1 por ejemplo.

Gracias por el interes mostrado.

Un saludo

Link to comment
Share on other sites

Re: Suma por referencia en dos hojas

Gracias Sebastian, en la primera columna funciona perfectamente, donde no me queda muy claro es en la segunda, creo que la formula de la primera esta bien es:

=SUMAPRODUCTO((Hoja2!$B$2:$B$6="SS1")*Hoja2!$C$2:$C$6*(Hoja2!$F$2:$F$6=E2))

En donde dice: ="SS1") aqui quizas deberia ser ="SS1" ¨SS2¨¨SS3¨ para que busque esos valores, pero no sé si es posible ya que lo intento y me dá error en la formula.

Ya sabes como se monta la formula para vendidos de SS1 por tienda, pues igual para SS2 y SS3 sumas las tres fórmulas o sumas los resultados.

Por otra parte como seria la formula para que buscar la referencia SS1 y que sume los vendidos y pedidos de la tienda 1 por ejemplo.

Gracias por el interes mostrado.

Un saludo

Lo mismo te digo monta las 2 fórmulas y las sumas o sumas los resultados.

Un saludo, Sebastian.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Crear macros Excel

  • Posts

    • A ver que tal, prueba y comenta Facturación 26082021JSD.xlsm
    • Hola, Yo no me entero muy bien; en el ejemplo que has puesto de  Puedes usar =IZQUIERDA(A1;4)/100 (suponiendo que el numero esta en A1). Seguro que no te refieres a eso porque es muy simple, pon mas ejemplos.
    • Hola a todos, soy nueva por aquí     Tengo una duda de una exportación de una tabla SQL, donde los precios de los productos, en lugar de exportarlos en formato moneda con decimales, me los exporta en el siguiente formato: "00.000.000" está en formato "número", pero no sé como hacer para pasarlo a un formato de moneda, ya que los últimos tres "0" me sobran y me suma los 8 dígitos, cuando los 3 últimos no valen.    Por ejemplo:  10.123.001 (Es un producto que vale 10,12€ Como puedo hacer para eliminar el resto de dígitos? No encuentro la manera y claro, tampoco puedo realizar operaciones en excel puesto que me suma todos los dígitos...   No sé si me he explicado bien...   Gracias!!  
    • Buenas , soy nuevo en esto de Macros , pero investigando he dado esta solución , El macro funciona con el directorio "C:\Excel\"  la llamada al Macro es " Analizar_archivos" desde Libro.xlsm Option Explicit Dim ArchivoAbrir As Excel.Workbook Sub Analizar_Archivos() Dim Dir, Carpeta, Archivo As Object Dim Ruta As String Dim Listado() As Variant Set Dir = CreateObject("Scripting.FileSystemObject") Ruta = "C:\Excel\" ' ruta donde mirar On Error GoTo Error Set Carpeta = Dir.GetFolder(Ruta) For Each Archivo In Carpeta.Files ' recorremos los archivos de la carpeta If InStr(1, Archivo.Name, "~$") = 0 And _ InStr(1, Archivo.Name, "xlsm") = 0 And _ Archivo.Name <> "C:\Excel\Libro.xlsm" Then ' exclusiones AbrirarchivoExterno (Ruta & Archivo.Name) ' abrimos el archivo End If Next Exit Sub Error: MsgBox "Ruta inexistente", vbCritical End Sub Sub AbrirarchivoExterno(Archivo) On Error Resume Next If Len(Archivo) > 0 Then Set ArchivoAbrir = Workbooks.Open(Archivo) Workbooks.Open(Archivo).Application.Visible = False ' abrimos el archivo en modo invisible Comprueba ' comprobamos el archivo abierto Cerrar (Archivo) ' cerramos el archivo abierto End If End Sub Sub Cerrar(Archivo) Set ArchivoAbrir = Workbooks.Open(Archivo) ArchivoAbrir.Save ArchivoAbrir.Close End Sub Sub Comprueba() Dim Texto As String Texto = Range("Bc30").Value Select Case Texto Case Is = "hogares" Range("bc30").Value = "infiernos" Case Is = "alquileres" Range("bc30").Value = "placeres" Case Is = "compartir" Range("bc30").Value = "genesis" Case "infiernos", "placeres", "genesis" Case Else Range("Bc30").Value = "" End Select End Sub    suerte.
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Privacy Policy