Jump to content

[SOLUCIONADO] Suma por referencia en dos hojas


sprit36

Recommended Posts

Hola a todos:

Tengo una duda, adjunto un ejemplo en el cual tengo por un lado en una hoja unos datos, en el ejemplo he puesto unos cuantos pero tengo muchos mas. Necesito una formula que en base a la referencia que es SS1, SS2 y SS3 sume de la Hoja2 el nº de articulos vendidos y por otra parte el nº de articulos no vendidos y pedidos.

Gracias.

Un saludo

Ejemplo1.zip

Link to comment
Share on other sites

Re: Suma por referencia en dos hojas

Gracias Sebastian, en la primera columna funciona perfectamente, donde no me queda muy claro es en la segunda, creo que la formula de la primera esta bien es:

=SUMAPRODUCTO((Hoja2!$B$2:$B$6="SS1")*Hoja2!$C$2:$C$6*(Hoja2!$F$2:$F$6=E2))

En donde dice: ="SS1") aqui quizas deberia ser ="SS1" ¨SS2¨¨SS3¨ para que busque esos valores, pero no sé si es posible ya que lo intento y me dá error en la formula.

Por otra parte como seria la formula para que buscar la referencia SS1 y que sume los vendidos y pedidos de la tienda 1 por ejemplo.

Gracias por el interes mostrado.

Un saludo

Link to comment
Share on other sites

Re: Suma por referencia en dos hojas

Gracias Sebastian, en la primera columna funciona perfectamente, donde no me queda muy claro es en la segunda, creo que la formula de la primera esta bien es:

=SUMAPRODUCTO((Hoja2!$B$2:$B$6="SS1")*Hoja2!$C$2:$C$6*(Hoja2!$F$2:$F$6=E2))

En donde dice: ="SS1") aqui quizas deberia ser ="SS1" ¨SS2¨¨SS3¨ para que busque esos valores, pero no sé si es posible ya que lo intento y me dá error en la formula.

Ya sabes como se monta la formula para vendidos de SS1 por tienda, pues igual para SS2 y SS3 sumas las tres fórmulas o sumas los resultados.

Por otra parte como seria la formula para que buscar la referencia SS1 y que sume los vendidos y pedidos de la tienda 1 por ejemplo.

Gracias por el interes mostrado.

Un saludo

Lo mismo te digo monta las 2 fórmulas y las sumas o sumas los resultados.

Un saludo, Sebastian.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Crear macros Excel

  • Posts

    • Buenas Tardes amigos, aca saludos desde Chile, quisiera vuestra ayuda , tengo este Excel el cual ocupamos cada  5 dias para enviar email masivos, enviamos aprox. 10.000 email, el tema es que cada email no tengo idea el porque, pero pesa entre 500 kg a 1 mega Aprox. y esto demora mucho, no se si se podrá hacer algo, y lo otro,  para cada mensaje debe ser personalizado si es hombre y mujer, habrá alguna forma de dejarlo unido si determina si es mujer u hombre?   le dejo el macros en caso me puedas ayudar para optimizar el macros que tengo por favor.   Se activa el macros, este copia el mensaje que esta en la hoja Datos  y lo pega en un correo nuevo en el Outlook , fue la unica opcion que pude lograr, no se si habra otra forma.     Sub ENVIARCORREONUEVO1211() Application.ScreenUpdating = False ThisWorkbook.Sheets("RS1").Select ActiveSheet.Range("B1:B26").Select x = ThisWorkbook.Sheets("Datos").Range("E5").Value For i = 1 To x ThisWorkbook.Sheets("Datos").Range("E6").Value = i ActiveWorkbook.EnvelopeVisible = True Application.ScreenUpdating = False With ActiveSheet.MailEnvelope    .Item.To = ThisWorkbook.Sheets("Datos").Range("E2").Value    ''.Item.cc = Con Copia a....''    .Item.Subject = ThisWorkbook.Sheets("Datos").Range("E3").Value    ' .Introduction = ThisWorkbook.Sheets("Datos").Range("E4").Value '        .Item.Send End With Next i Application.ScreenUpdating = True End Sub  
    • Hola,   No me funciona.   Sale este error.   Seria posible tambien no tener que editar la ruta cada vez y que coja la ruta donde esta el xlsm?   Muchas gracias
    • A ver que tal, prueba y comenta Facturación 26082021JSD.xlsm
    • Hola, Yo no me entero muy bien; en el ejemplo que has puesto de  Puedes usar =IZQUIERDA(A1;4)/100 (suponiendo que el numero esta en A1). Seguro que no te refieres a eso porque es muy simple, pon mas ejemplos.
    • Hola a todos, soy nueva por aquí     Tengo una duda de una exportación de una tabla SQL, donde los precios de los productos, en lugar de exportarlos en formato moneda con decimales, me los exporta en el siguiente formato: "00.000.000" está en formato "número", pero no sé como hacer para pasarlo a un formato de moneda, ya que los últimos tres "0" me sobran y me suma los 8 dígitos, cuando los 3 últimos no valen.    Por ejemplo:  10.123.001 (Es un producto que vale 10,12€ Como puedo hacer para eliminar el resto de dígitos? No encuentro la manera y claro, tampoco puedo realizar operaciones en excel puesto que me suma todos los dígitos...   No sé si me he explicado bien...   Gracias!!  
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Privacy Policy