Jump to content

[Solucionado] Buscando coincidencias


Guest jorgeclon

Recommended Posts

Guest jorgeclon

Buenas tardes, tengo el siguiente problema, se que excel 2003, deja tener un máximo de 30 validaciones para la función SI, lo que e investigado es hacer una función anidada o colocar la otra función en una celda y luego meterla en esta formula, lo que pasa es que son mas de 60 datos o malos lugares para validar.

=IF(OR(R2=""SUPERMERCADOS"",R2=""HIPERMERCADO/MAYORISTAS"",R2=""OTROS CANALES"",R2=""FACTURA"",R2=""ALMACENES POR DEPARTAMENTO"",R2=""TELEFONIA"",R2=""TIENDAS"",R2=""DROGUERIAS/FARMACIAS"",R2=""TIENDA ESPECIALIZADA"",R2=""TELEMERCADEO"",R2=""2 x 3"",R2=""LAS GATAS"",R2=""FEBOR"",R2=""FULLER"",R2=""BARANQUILLITA"",R2=""CAFAM"",R2=""YEP"",R2=""CARULLA"",R2=""SAN VICTORINO"",R2=""COLSUBSIDIO"",R2=""ATACADAO"",R2=""POMONA"",R2=""OKAVANGO"",R2=""Q PRECIOS"",R2=""VIVERO"",R2=""TIA"",R2=""ONLY"",R2=""CASA ESTRELLA"",R2=""HOMECENTER"",R2=""CAJASAN""),""ERROR"",""OK"")"[/HTML]

Faltaría meter:

R2=""GRANERO"", R2=""EFECTIVO"",R2=""OTROS ALMACENES DE FOTOGRAFIA"" Y 27 MAS.

Gracias

Un Saludito

Link to post
Share on other sites

Re: Como Hacer para incrementar esta formula con más valores.

Hola jorgeclon, prueba con esta fórmula en inglés:

=IF(ISERROR(MATCH(R2,A1:A100,0)),"OK","ERROR")[/CODE]

Creando una lista con los 100 datos en el rango A1:A100 por ejemplo.

La misma fórmula en español:

[CODE]=SI(ESERROR(COINCIDIR(R2;A1:A100;0));"OK";"ERROR")[/CODE]

para los demás foreros.

Link to post
Share on other sites
Guest jorgeclon

Re: Como Hacer para incrementar esta formula con más valores.


Range("AK2").Formula = "=IF(ISERROR(MATCH(R2,MALOSLUGARES!$A$2:$A$100,0)),""OK"",""ERROR"")"
Range("AK2:AK" & N + 1).FillDown[/CODE]

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Crear macros Excel

  • Posts

  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy