Jump to content

SEBASTIAN67

Members
  • Posts

    487
  • Joined

  • Last visited

  • Days Won

    6

Everything posted by SEBASTIAN67

  1. Re: consulta Calendario Revisa adjunto y comenta: Fechas_io_ST_faeSS.zip
  2. Re: Buscarv Condicionado Sumaproducto es una formula que te dará mucho juego. Al principio es un poco complicada entenderla pero una vez la conozcas bien la usaras mucho. En C2 y copias hacia abajo:
  3. Re: Modificar Formula EXTRAER No lo he probado, mira si vá.Un saludo, Sebastian.
  4. Revisa adjunto y comenta: Un saludo, Sebastian. Costeo de PrestacionesSS.zip
  5. Sub eliminarfilas() x = ActiveSheet.Cells(Rows.Count, 1).End(xlUp).Row Range("b2").Activate For a = 2 To x If ActiveCell = "" Then Range(Cells(a, 1), Cells(x, 3)).Delete Shift:=xlUp End Else ActiveCell.Offset(1, 0).Activate End If Next End Sub[/CODE] Crea un boton en tu hoja y asígnale esta macro. Un saludo, Sebastian
  6. A partir de tu formula en la columna C con INDICE COINCIDIR es suficiente
  7. Otra sin columna auxiliar, con fórmulas matriciales: muestramatricialSS.zip
  8. Revisa adjunto: Un saludo, Sebastian. muestraSS.zip
  9. Con tu permiso Gerson y saludos: Sub imprimirseleccion() With Range("C1", Range("D1").End(xlDown)).Select .PrintOut Copies:=1, Collate:=True End With End Sub[/CODE]
  10. Re: Búsquedas con varios parametros + filtros y opciones de selección Subo en rar ya que zip no comprime lo suficiente, ruego me disculpen aquellos que no puedan descomprimir rar. Adjunto tu archivo pero he tenido que recortar la bbdd para disminuir el tamaño de este, copia tu base de datos a este archivo y arrastra las formulas que estan en las 4 ó 5 columnas junto a la base de datos hasta el final de tu base. Esto es para crear un desplegable para los códigos en la hoja digitacion´estos deesplegables se actualizan con una macro, es por lo que te digo que copies de tu archivo a este y no de este al tuyo, aunque también puedes pasar el codigo vba que esta en el modulo de la Hoja digitacion a tu libro. Un saludo, Sebastian. EDITO:http://www.megaupload.com/?d=56FTA0R6 en este enlace esta completo sin recortes. digitacionrespaldoSSS.rar
  11. Re: Cuadrante Control Horario =(CONTAR.SI(B6:B36;$A$41)+CONTAR.SI(B6:B36;$A$42)+CONTAR.SI(B6:B36;$A$43)+CONTAR.SI(B6:B36;$A$44))*8[/CODE] Para total de jose Un saludo, Sebastian.
  12. Re: Suma por referencia en dos hojas Espero que esto sulucione tus dudas: Un saludo, Sebastian. vendidonovendidoSSS.2.zip
  13. Re: problema con lista y campo vacio Un adjunto seria lo suyo; daremos palos al agua: esta para I2 Un saludo, Sebastian.
  14. Re: restar horas y diasen celdas por separado prueba y comenta Un saludo, Sebastian.
  15. Re: Sumar por nif Te adjunto archivo con la suma de irpf en la otra columna no se que hay que sumar pero la forma puede ser la misma, esto te vale siempre y cuando los datos esten ordenados de la forma que estan: Sumasirpf.zip
  16. Re: Suma por referencia en dos hojas Ya sabes como se monta la formula para vendidos de SS1 por tienda, pues igual para SS2 y SS3 sumas las tres fórmulas o sumas los resultados. Lo mismo te digo monta las 2 fórmulas y las sumas o sumas los resultados. Un saludo, Sebastian.
  17. Re: Suma por referencia en dos hojas Revisa adjunto: vendidonovendidoSSS.1.zip
  18. Re: Suma por referencia en dos hojas revisa adjunto y comenta: y lo subo con columnas en letras vendidonovendidoSSS: vendidonovendidoSS.zip vendidonovendidoSSS.zip
  19. Algo más simple para convertir tus textos a numeros: =EXTRAE(B3;2;LARGO(B3)-1)*1[/CODE] Un saludo, Sebastian.
  20. Saludos Ioyama, veo que ya has dado una solución, permiteme otra opción, esta con dos botton como tenia el archivo, una para filas y otra para columnas, ademas e modificado también la macro de restaurar: COLUMNAS Y FILAS filtroSS.zip
  21. Re: sumar tiempos con la misma fecha No ibas mal encaminado con sumaproducto: suma_horas_fechaSS.zip
  22. Re: Extraer datos de una cadena de texto Una combinación de extraer y hallar: Un saludo, Sebastian. extraer coordenadasss.zip
  23. En la ficha del formato debes de elegir formula y esta seria: El problema es que al arrastrarla las referencias al ser absolutas no cambian por lo que no sirve. Una solucion seria montar el formato condicional celda por celda (trabajo de chino, por cierto a los que no les va mal). Otra solucion mejor es recurrir a una macro para que ella hiciera el trabajo sucio: Sub FORMATOSFLECHAS() ' ' FORMATOSFLECHAS Macro ' ' Acceso directo: CTRL+f Dim A1 As String Dim B1 As String 'COLOCAR CURSOR EN LA CELDA DE LA IZQUIERDA DONDE QUEREMOS EL 1º FORMATO For A = 1 To 20 'EJEMPLO PARA 20 FILAS; CAMBIA EL 20 POR EL NUMERO DE FILAS ActiveCell.Offset(0, 1).Range("A1").Select A1 = ActiveCell.Offset(0, -1).Address B1 = ActiveCell.Address Selection.FormatConditions.AddIconSetCondition Selection.FormatConditions(Selection.FormatConditions.Count).SetFirstPriority With Selection.FormatConditions(1) .ReverseOrder = False .ShowIconOnly = False .IconSet = ActiveWorkbook.IconSets(xl3ArrowsGray) End With With Selection.FormatConditions(1).IconCriteria(2) .Type = xlConditionValueFormula .Value = "=SI(" & A1 & "-" & B1 & "=0;" & B1 & ";SI(" & A1 & "-" & B1 & "<0;" & B1 & "-1;" & B1 & "+1))" .Operator = 7 End With With Selection.FormatConditions(1).IconCriteria(3) .Type = xlConditionValueFormula .Value = "=SI(" & A1 & "-" & B1 & "=0;" & B1 & ";SI(" & A1 & "-" & B1 & "<0;" & B1 & "-1;" & B1 & "+1))" .Operator = 5 End With ActiveCell.Offset(1, -1).Range("A1").Select Next End Sub [/CODE] esta macro introduce el formato en 20 filas se puede adaptar a tu archivo si tienes problemas no dudes en preguntar. te adjunto un ejemplo: Un saludo, Sebastian. FORCONDFLECHASSS.zip
  24. Utiliza la formula en B14: En el listado amarillo creo que debe de estar al igual que el azul en vertical. Un saludo, Sebastian.
×
×
  • Create New...

Important Information

Privacy Policy