Jump to content

curanilahue

Members
  • Posts

    168
  • Joined

  • Last visited

Posts posted by curanilahue

  1. Como es sabido, cuando hablamos de calcular con decimales, en excel, no siempre las aproximaciones son lo que queremos.

    Por ejemplo en mi caso al sumar varias notas escolares, la suma y correspondiente división me entrega 5,9; sin embargo es 5,96.

    Nota que quiero aproximar o redonder (no lo se) a 6.0

    Que función o fórmula me permite realizar aquello????

    Aclaro que ese 5,96 es el resultado de notas ya aproximadas anteriormente, también mediante excel

  2. La verdad Nolberto es que la planilla excel la tengo diseñada, que no es gran cosa, me falta el formulario donde se trasladarán los datos en definitiva y que es el informe que se imprimirá que pienso podría ser un documento de word.

    El problema es que he tenido una serie de actividades laborales que me han impedido el termino de ambos. Nunca trabajo tanto. jajajajaj Agradecido.

  3. En realidad eso es lo que me interesa a mi también, claro que el problema en particular lo solucioné, momentaneamente, colocando las notas en números enteros ( 67, 68, 56, 44, 60) y en la columna que va el promedio dividirlas por 10

    ejemplo: =SI(ESERROR(PROMEDIO(E7:N7)/10);""; PROMEDIO(E7:N7)/10)

    el unico problema es que hay que tener cuidado en darle formato de celda y dejar la celda como "general" . Reitero, también es para una sola columna.

  4. Debo elaborar informes de notas. Los profesores deben ingresar sus calificaciones, lamentablemente, muchas veces colocan un punto para separar decimales y simplemente nada, (5.4 o 54).

    Mi deseo es que automaticamente al escribir 54, aparezca la coma separando el decimal.

    Agradecido desde ya

  5. Leyendo algunos ejemplos se me ocurre consultar (aunque no tengo un modelo aun).

    Mi actividad consiste en realizar servicio técnico de computadores y otras actividades informáticas de las que hasta ahora no se lleva registro. Por tanto nadie sabe la cantidad de trabajo que si o no desarrollo.

    Se me ocurre poder generar un informe por cada trabajo que realize, donde aparezca la falla resuelta, el material empleado, el departamento a que pertenece, fecha de recepción y entrega, firma del receptor, entre otros.

    Ejemplo en planilla excel se copian a renglon seguido todos estos datos, que de inmediato generan un informe en word o el propio excel que se imprima y se entreguey que además vaya quedando como base de datos.

    Esto podría ser similar a la combinación de correspondencia o algo similar.

    Si alguien puede ayudarme, se lo agradeceré (que es lo menos que puedo hacer)

    Ahhh estuve viendo el programa CP Reparaciones, pero no me llena.

  6. Respuesta: Rol Unico Nacional Chileno, verificarlo

    Esta buena, y realiza la misma función de una macro que actualmente estoy usando. Por si le sirve a algún amigo de la red les dejo la mencionada macro:

    Function RutChileno(strRut As String) As String

    Dim intP As Integer

    Dim intSum As Integer

    Dim intNro As Integer

    Dim intRut As Integer

    intNro = 2

    For intP = Len(strRut) To 1 Step -1

    intSum = intSum + intNro * Val(Mid(strRut, intP, 1))

    intNro = IIf(intNro = 7, 2, intNro + 1)

    Next

    intRut = 11 - (intSum Mod 11)

    RutChileno = IIf(intRut >= 10, IIf(intRut = 10, "K", "0"), CStr(intRut))

    End Function

    se usa llamando la función =dv(Celda donde está el numero antes de la raya)

  7. Respuesta: Rol Unico Nacional Chileno, verificarlo

    Encontré una solución para el tema, un poco largo pero solución al fin:

    En la columna (desde) F4 van los numeros de RUT, ejemplo 17.465.988-5; 17.465.988-5; 17465988-5;00.000.000-0; 15.370.853-3

    En la columna siguiente G4 hacia abajo esta fórmula:

    =SI(11-RESIDUO((EXTRAE(F4;LARGO(F4)-2;1)*2)+(EXTRAE(F4;LARGO(F4)-3;1)*3)+(EXTRAE(F4;LARGO(F4)-4;1)*4)+(EXTRAE(F4;LARGO(F4)-6;1)*5)+(EXTRAE(F4;LARGO(F4)-7;1)*6)+(EXTRAE(F4;LARGO(F4)-8;1)*7)+(EXTRAE(F4;LARGO(F4)-10;1)*2)+(SI(EXTRAE(F4;LARGO(F4)-11;1)<>"";(EXTRAE(F4;LARGO(F4)-11;1)*3);""));11)=11;0;SI(11-RESIDUO((EXTRAE(F4;LARGO(F4)-2;1)*2)+(EXTRAE(F4;LARGO(F4)-3;1)*3)+(EXTRAE(F4;LARGO(F4)-4;1)*4)+(EXTRAE(F4;LARGO(F4)-6;1)*5)+(EXTRAE(F4;LARGO(F4)-7;1)*6)+(EXTRAE(F4;LARGO(F4)-8;1)*7)+(EXTRAE(F4;LARGO(F4)-10;1)*2)+(SI(EXTRAE(F4;LARGO(F4)-11;1)<>"";(EXTRAE(F4;LARGO(F4)-11;1)*3);""));11)=10;"k";(11-RESIDUO((EXTRAE(F4;LARGO(F4)-2;1)*2)+(EXTRAE(F4;LARGO(F4)-3;1)*3)+(EXTRAE(F4;LARGO(F4)-4;1)*4)+(EXTRAE(F4;LARGO(F4)-6;1)*5)+(EXTRAE(F4;LARGO(F4)-7;1)*6)+(EXTRAE(F4;LARGO(F4)-8;1)*7)+(EXTRAE(F4;LARGO(F4)-10;1)*2)+(SI(EXTRAE(F4;LARGO(F4)-11;1)<>"";(EXTRAE(F4;LARGO(F4)-11;1)*3);""));11))))

    en la columna H4 hacia abajo esta formula

    =EXTRAE(F4;12;1)

    en la columna I4 hacia abajo esta formula

    =SI(G4="k";11;G4)*2

    en la columna J4 hacia abajo esta formula

    =SI(H4="k";11;H4)*2

    en la columna K4 hacia abajo esta formula

    =SI(ESERROR(SI(I4=J4;"OK";"ERROR"));"";(SI(I4=J4;"OK";"ERROR")))

    Para ello todo tendría que partir en la columna F y terminar en la K

    ¿Habrá algo más simple?

  8. Respuesta: Rol Unico Nacional Chileno, verificarlo

    Si efectivamente, después de buscar bastante me encontré con varias formas que dan el dígito verificador (DV), y utilice para mis fines una macro de esas.

    Es decir coloco el numero que va antes del guion 12.345.456 y el macro me da automáticamente el DV (según yo en ese momento debería estar correcto el RUN o RUT.

    Lo que yo quería era colocar el numero completo, ejemplo 12.345.456-7 y me dijera correcto si esta bien o error si estaba mal. Al final me parece que la solución que implementé da más o menos lo mismo.

    Ahora si quieren experimentar algo puedo enviar lo que he dejado funcionando.????

  9. Tengo un largo listado de personas con sus nombres y números de Rol ünico Nacional, RUN (que es la cédula de identidad chilena) y que actúa indiferentemente para trámites civiles y tributarios (aunque en este último se conoce como Rol Único Tributario, RUT).

    Este número contiene el "número" propiamente tal y un dígito verificador que va desde el 0 al 9 y en algunos casos la latra K.

    Necesito que de alguna forma, al ingresarlo en una celda adyacente se me indique si es verdadero o falso. Ya que necesito determinar cuales son buenos para no tener que estar rectificando posteriormente, sino en ese mismo momento.

    Habrá algún aporte sobre eso???. Agradecido.

  10. Respuesta: Como Promediar notas con conceptos

    Perfectamente entendido mjofra probé las fórmulas arreglando el tema de los rangos a mis necesidades es decir:

    1,0 a 3,9

    4,0 a 4,9

    5,0 a 5,9

    6,0 a 7,0

    En las primeras todo funciona excelente; pero en las notas limites o sea 4,0 - 5,0 - 6,0 no las contabiliza (las restantes no hay problema) de arreglarse esta parte me evita un tremendo camino de la fórmula que uso actualmente. Por lo tanto sería muy funcional.

    El otro problema viene en la matricial. NUNCA he entendido eso ni la forma como ingresarla,si puedes darme algún tutorial donde leer el tema te lo agradecería. Por ello mismo, en esa forma que me parece mejor aún no logro hacerla funcionar.

    Agradecido.

    En realidad estuve trabajando en los rangos, curiosamente me di cuenta que estos no funcionan como yo creia, sino que como tu los confeccionastes, es decir.

    Para nota: Insuficiente de 1,00 a 3,9 la fórmula sería:

    =CONTAR.SI(AL$3:AL$47;"<=3,9")-CONTAR.SI(AL$3:AL$47;"<=0,0")

    para que cuente el 1,0

    para el rango 4,0 a 4,9

    =CONTAR.SI(AL$3:AL$47;"<=4,9")-CONTAR.SI(AL$3:AL$47;"<=3,9")

    de otra manera no cuenta el 4,0

    Para el rango 5,0 a 5,9

    =CONTAR.SI(AL$3:AL$47;"<=5,9")-CONTAR.SI(AL$3:AL$47;"<=4,9")

    para el rango 6,0 a 7,0

    =CONTAR.SI(AL$3:AL$47;"<=7,0")-CONTAR.SI(AL$3:AL$47;"<=5,9")

    Obviamente acepto aclaraciones o correcciones respecto a mi interpretación.

  11. Respuesta: Como Promediar notas con conceptos

    Para no crear un tema nuevo, aunque siempre en el ámbito escolar, he adaptado una tabla para contar los promedios de acuerdo a ciertos rangos, por ejemplo de 1 a 3,9 (I); 4,0 a 4,9 (S); 5,0 a 5,9 (B) y 6,0 a 7,0 (MB).

    Esto porque las Unidades Técnicas de los colegios chilenos solicitan esta estadística de cada curso y resulta engorroso realizarla manualmente.

    La formula debiera quedar algo asi como:

    =CONTAR.SI(C23:C27;"<=3,9") que es la que me resulta para el primer rango; pero se me complica para los siguientes ya que no manejo el tema de los números decimales en las fórmulas.

    Agradeceré algunas sugerencias.

  12. Respuesta: Como Promediar notas con conceptos

    Exactamente como lo indicas es la solución para el tema. Debo reconocer que la forma desarrollado y aportada por Ernesto_Uy es también buena. Pero esta última pasa por alto las columnas auxiliares, por lo que es más corto de realizar. Lo acabo de integrar al informe de prueba y seguramente dentro de la semana al definitivo que además subiré a algunas páginas chilenas para ofrecerlo a otros colegas que seguramente deben tener este mismo problema, pòr lo que desde ya y siempre Muchas gracias por el aporte a ambos.

    Un fuerte abrazo hermano Excelboy.

  13. Respuesta: Como Promediar notas con conceptos

    Excelente trabajo, solo le mofifiqué un detalle para que quedara en blanco la celda cuandso no haya ningún resultado. El problema se produjo cuando la trasladé al segundo semestre y al promedio final, no salió nada.

    Ah, en el primer semestre, la fórmula quedó así.

    =SI(ESERROR(INDICE({"I";"S";"B";"MB"};REDONDEAR(SUMAPRODUCTO(COINCIDIR(DESREF(E6;0;0;1;CONTARA(E6:N6));{"I";"S";"B";"MB"};0))/CONTARA(E6:N6);0)));"";INDICE({"I";"S";"B";"MB"};REDONDEAR(SUMAPRODUCTO(COINCIDIR(DESREF(E6;0;0;1;CONTARA(E6:N6));{"I";"S";"B";"MB"};0))/CONTARA(E6:N6);0)))

    Dale una mirada y lo que puedas hacer por el segundo semestre y el promedio de ambos semestres.

  14. Respuesta: Como Promediar notas con conceptos

    Nuestro amigo Ernesto_uy realizó una adecuación de este modelo, integrandola al mio.

    En este caso el creador estableció una forma exitosa, por lo que te envío aquella, amigo Excelboy, desde allí puedes trabajar en la simplificación del método que para mi resultó demasiado engorroso.

    http://rapidshare.com/files/321594365/2.-_Informe_de_notas_Koal_V2.xls.html

    Si puede simplificar el método seramos agradecidos.

  15. Respuesta: Como Promediar notas con conceptos

    Un enorme agradecimienro para Ernesto_uy, ya que con mucho entusiamo logró finalmente lo que estaba pidiendo para realizar este trabajo en el colegio donde trabajo.

    Claro que no será la primera ni la última vez en que los estaré molestando. Agradecido de que haya un sitio así; que apoye a los que tenemos solo las ganas.

    Reitero mi abrazo Ernesto..... y doy por finalizado el tema........(por ahora)

×
×
  • Create New...

Important Information

Privacy Policy