Jump to content

Dani2020

Members
  • Posts

    38
  • Joined

  • Last visited

Reputation Activity

  1. ¡Excelente!
    Dani2020 reacted to Antoni in Macro para buscar en base de datos por código   
    Private Sub Worksheet_Change(ByVal Target As Range) Dim uFo&, nom% On Error GoTo Salida If Not Intersect(Range("F:F"), Target) Is Nothing Then If Target.Text <> "" Then With Sheets("Datos") uFo = .Range("A" & Rows.Count).End(xlUp).Row nom = Target Target.Offset(, 1) = WorksheetFunction.VLookup(nom, .Range("$A$1:$B$" & uFo), 2, 0) End With End If Exit Sub End If '-- If Target.Address = "$G$2" Then MESES Exit Sub End If '-- Application.ScreenUpdating = False Dim celda As Range If Not Intersect(Target, Range("I7:AM" & Range("FIN").Row)) Is Nothing Then Application.EnableEvents = False For Each celda In Target celda = UCase(celda) Select Case celda Case "T": celda.Interior.Color = RGB(0, 204, 204) Case "L": celda.Interior.Color = RGB(119, 210, 85) Case "DLJ": celda.Interior.Color = RGB(255, 204, 204) Case "V": celda.Interior.Color = RGB(255, 255, 204) Case "C": celda.Interior.Color = RGB(255, 229, 204) Case "BI": celda.Interior.Color = RGB(189, 183, 107) Case "HA": celda.Interior.Color = RGB(65, 105, 225) Case "RDF": celda.Interior.Color = RGB(255, 0, 0) Case Else: celda.Interior.ColorIndex = xlNone End Select Next End If '-- Salida: Application.EnableEvents = True End Sub  
  2. Thanks
    Dani2020 reacted to Antoni in Macro para buscar en base de datos por código   
    Pon la fórmula en B2 y arrastra hacia abajo:
    =SI(A2<>"";BUSCARV(A2;BD!A:B;2);"")
    .
  3. Thanks
    Dani2020 reacted to Haplox in Macro para buscar en base de datos por código   
    Te dejo la solución con macros. EL código esta en el evento de la Hoja datos, así que se ejecuta automáticamente al poner el código.
    Pero no te hubiese hecho falta macro, con la fórmula siguiente en la columna B obtienes el mismo resultado
    =BUSCARV(A2;BD!$A$2:$B$8;2)
    Copia de Libro1.xlsm
  4. Like
    Dani2020 got a reaction from MauriciodeAbreu in Imprimir PDF desde Excel con macros   
    Pruebe este
    Sub CreaPDF()
    Dim NombreArchivo, RutaArchivo As String
    NombreArchivo = ActiveSheet.Name
    RutaArchivo = ActiveWorkbook.Path & "\" & NombreArchivo & ".pdf"
    ActiveSheet.ExportAsFixedFormat Type:=xlTypePDF, Filename:=RutaArchivo, _
    Quality:=xlQualityStandard, IncludeDocProperties:=True, _
    IgnorePrintAreas:=False, OpenAfterPublish:=False
    End Sub
     
  5. Thanks
    Dani2020 reacted to Antoni in Macro que automáticamente  rellene celdas de 2 en 2    
    Pon esta macro en la hoja:
    Private Sub Worksheet_Change(ByVal Target As Range) If Target.Address = "$A$1" Then If Target = "" Then Range("E1:E20").ClearContents 'Borra el rango E1:E20 si se borra A1 Else Range("A3,A5,A7,A9,A11") = Target 'Duplica A1 en A3,A5,A7,A9,A11 End If End If End Sub  
  6. Like
    Dani2020 got a reaction from Antoni in Modificar Macro trimestre   
    Muchas Gracias Antoni, excelente trabajo era lo que ocupaba 
  7. Thanks
    Dani2020 reacted to Antoni in Modificar Macro trimestre   
    A diferencia de las fórmulas de Excel, VBA no se adapta de forma automática cuando añadimos/eliminamos filas/columnas.
    El problema se ha originado al añadir 2 filas al principio de la hoja Datos.
    La lista de meses debe estar si o si en el rango Datos!F3:F14, de lo contario, hay que modificar la macro MESES.
    Te he reestructurado un poco el evento Change.
    ROL DE DÍAS LIBRES POR JORNADA III TRIMESTRE ESTACION DE OROTINA VERSION 2.xlsm
  8. Thanks
    Dani2020 reacted to Antoni in Modificar Macro trimestre   
    A ver si es eso.
    ROL DE TRABAJO DEL PERSONAL POR JORNADA.xlsm
  9. Thanks
    Dani2020 reacted to Janlui in Control de días libre del persona por trimestres   
    Espero que este sea el bueno, y no olvides dar clic en el corazoncito del lado inferior derecho si damos por concluido este tema.
     
    Saludos
    TRIMESTRES VER 2.xlsm
  10. ¡Excelente!
    Dani2020 reacted to Janlui in Control de días libre del persona por trimestres   
    espero te sirva y no olvides dar clic en el corazoncito lado izquierdo si tu petición fue atendida.
    Saludos
    TRIMESTRES.xlsm
×
×
  • Create New...

Important Information

Privacy Policy